Netbrain
Home NetBrain Product One-Skill-at-a-Time Search Mark Forums Read
Go BackThe Net-BrainerOne-Skill-at-a-Time Passing MPLS traffic through 6500

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-02-2010, 12:43 AM
m.stone m.stone is offline
 
Join Date: Dec 2009
Posts: 29
Default Passing MPLS traffic through 6500

Dear Experts,

I have a 6500 switch running normal IP traffic . Now I want to pass some traffic through this 6500 , but i don't want this to affect the normal routing table

So I decided to do the config. as given below . Now my concern is Is there is any limitation in doing this ?

Another concern is that whether this config. will work fine if I don't have any physical interface with tag switching ?

ip vrf test
rd 1:98
route-target export 1:98
route-target import 1:98


interface Vlan10
ip vrf forwarding test
ip address 192.168.1.1 255.255.255.0


int int range gigabitEthernet 3/13 - 15
switchport
switchport access vlan 10


interface GigabitEthernet3/7
description uplink to Customer


interface GigabitEthernet3/7.1
encapsulation dot1Q 667
ip vrf forwarding test
ip address 10.25.4.3 255.255.255.0


ip route vrf 0.0.0.0 0.0.0.0 10.25.4.1

Please help me to give an answer . I will rate the helpful comments

regards


Michael
Reply With Quote
Old 03-02-2010, 10:27 PM
ashley ashley is offline
 
Join Date: Jan 2010
Posts: 18
Default Re: Passing MPLS traffic through 6500

Michael,

So what you are doing is:

create a VLAN 10 with his SVI part of the "test" VRF. In the switchports part of VLAN 10 I assume that you will attach some customer related servers or end point.

Then you create a subinterface connected with the next hop at the customer, also part of the "test" VRF.

This will create a "test" VRF routing table with 2 connected subnets: 192.168.1.0/24 and 10.25.4.0/24. Off course you will need a default gateway towards your next hop at the customer but here you made a small mistake:

you should include the VRF name in your static route:

ip route vrf test 0.0.0.0 0.0.0.0 10.25.4.1

After this you will have a fully operational environment without any impact on your current and global routing.

Regards,
Ash
Reply With Quote
Old 03-02-2010, 11:33 PM
Chris Chris is offline
 
Join Date: Jun 2009
Posts: 74
Default Re: Passing MPLS traffic through 6500

Hello Michael,

>> will work fine if I don't have any physical interface with tag switching ?

it can work if you provide a full path for the VRF, if all you want is to route packets originated in vlan 10 IP subnet to that IP next-hop you are fine.

What you have done is called VRF lite or multi VRF CE that is using VRFs without using MPLS forwarding.

if you have two or more VRFs a distinct exit point for each VRF is needed (at least at logical level)

This makes VRF lite less scalable then standard MPLS L3 VPN where you use a backbone link for all possible VRFs by using MPLS forwarding plane.


Hope to help
Reply With Quote
Old 03-04-2010, 10:02 PM
m.stone m.stone is offline
 
Join Date: Dec 2009
Posts: 29
Default Re: Passing MPLS traffic through 6500

Quote:
Originally Posted by Chris View Post
Hello Michael,

>> will work fine if I don't have any physical interface with tag switching ?

it can work if you provide a full path for the VRF, if all you want is to route packets originated in vlan 10 IP subnet to that IP next-hop you are fine.

What you have done is called VRF lite or multi VRF CE that is using VRFs without using MPLS forwarding.

if you have two or more VRFs a distinct exit point for each VRF is needed (at least at logical level)

This makes VRF lite less scalable then standard MPLS L3 VPN where you use a backbone link for all possible VRFs by using MPLS forwarding plane.


Hope to help

Hi, Chris

Thanks for your helpful answer ..

I rated it
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump

All times are GMT -4. The time now is 06:34 PM.
Powered by vBulletin
Copyright 2000-2010 Jelsoft Enterprises Limited.
Copyright 2009 NetBrain, Inc. All rights reserved.